HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
Making threads to link to banned members content grants an automatic ban
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 Loginserver works, gameserver doesn't

View previous topic View next topic Go down 
AuthorMessage
venw0lf

avatar

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 98
Join date : 2015-05-14
Age : 15
Location : off the grid

PostSubject: Loginserver works, gameserver doesn't   Fri Jul 14, 2017 5:15 pm

I just got a server working, and when tested, loginserver works great. The player that tested was able to connect and login, and the application displays the proper ips after ID_NEW_INCOMING_CONNECTION from

Whenever the player pressed Start however, they could not connect. Connection request had failed.
So I did some poking around and tested it on my end.
Strangely enough, the gameserver application shows the ID connection thing as 127.0.0.1 when I connected, which doesn't make sense to me?
When the player tries to connect and gets the failed message, nothing appears inside gameserver

I can connect just fine.
I do not have localip in my copy of the game. Do I need to have that?
I do have Pingrange in the game.
I have ports 40000 and 40010 port forwarded for udp and tcp on my router
I opened those ports in windows firewall as well.
I am using No-ip
Back to top Go down
Misspinker

avatar

Game username : Misspink
Server : |~|N/A |~| Skills: Hosting, Modeling, Rigging. Age:18
Female Posts : 269
Join date : 2015-02-15
Location : Everywhere.

PostSubject: Re: Loginserver works, gameserver doesn't   Fri Jul 14, 2017 5:29 pm

Hello venwolf,
Did you put your Ip address in the source code and removed 127.0.0.1? 127.0.0.1 is the testing ip address/default so you'll want to use your own when port forwarding.
Back to top Go down
http://magrose.portfoliobox.net/startpage
venw0lf

avatar

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 98
Join date : 2015-05-14
Age : 15
Location : off the grid

PostSubject: Re: Loginserver works, gameserver doesn't   Fri Jul 14, 2017 6:22 pm

Yes, I put my No IP name that I chose in as the Ip in the source code
I'm really confused as to why one server works and the other doesn't when I portforwarded them all at the same time and it's the same for each one..?
Back to top Go down
Skyia

avatar

Game username : Skyia
Server : Royal Elements
Female Posts : 138
Join date : 2014-09-14
Age : 16
Location : In your mind

PostSubject: Re: Loginserver works, gameserver doesn't   Sat Jul 15, 2017 8:31 am

or you can make a localip.txt and put your IP in there and in the compile also. Now this lets you in but no one else btw

(if im reading it right)
Back to top Go down
venw0lf

avatar

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 98
Join date : 2015-05-14
Age : 15
Location : off the grid

PostSubject: Re: Loginserver works, gameserver doesn't   Sat Jul 15, 2017 11:35 pm

The problem is that only I can connect to the game. No one else can.
Loginserver works, but gameserver only works for me and no one else
Back to top Go down
Misspinker

avatar

Game username : Misspink
Server : |~|N/A |~| Skills: Hosting, Modeling, Rigging. Age:18
Female Posts : 269
Join date : 2015-02-15
Location : Everywhere.

PostSubject: Re: Loginserver works, gameserver doesn't   Sun Jul 16, 2017 2:46 am

Is your issue similar to this solved supported question?:
http://www.kitopen.com/t4512-no-servers-to-connect-to-solved

You've stated that your Ip in the source is your NoIP name but it really should be your ipv4 address by searching up on google 'what is my ip'. Make sure your ports are open both in your firewall and in your router. When port-forwarding and sending the game to your friends make sure you do NOT send them the client with localip.txt or else it wont work for them.

If you are still having this issue, and have tried the method stated above, you may add me on skype as *removed username for privacy venwolf has contacted me* so that I may help you in chat there. When adding me on skype please state that you are from kito so that I know it is you.


Last edited by Misspinker on Wed Jul 19, 2017 2:06 am; edited 1 time in total
Back to top Go down
http://magrose.portfoliobox.net/startpage
venw0lf

avatar

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 98
Join date : 2015-05-14
Age : 15
Location : off the grid

PostSubject: Re: Loginserver works, gameserver doesn't   Sun Jul 16, 2017 5:17 pm

So then... If the servers are using my Ipv4 IP what's the point of even using No-Ip?
I'll follow what the thread said, but my error is Connection Request Has Failed, nothing about having no server.
Also no, the player doesn't have localip.txt
Back to top Go down
ObeyTheFist

™
avatar

Game username : ObeyTheFist
Server : Dragon's Den
Female Posts : 498
Join date : 2012-09-07
Location : Australia

PostSubject: Re: Loginserver works, gameserver doesn't   Mon Jul 17, 2017 1:58 pm

If you're going through no-ip then you need to use the name of your domain and not an actual IP address in your compile.
Back to top Go down
http://dragonsden.freeforums.net
venw0lf

avatar

Game username : Venwolf
Server : Last Moon (Global Mod)
Female Posts : 98
Join date : 2015-05-14
Age : 15
Location : off the grid

PostSubject: Re: Loginserver works, gameserver doesn't   Mon Jul 17, 2017 5:09 pm

I had "gamenamehere.ddns.net" in as the Main Server IP.
I haven't tried just putting my IPv4 IP in there because I thought that would defeat the purpose of having No-ip in the first place.
Back to top Go down
 
Loginserver works, gameserver doesn't
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support-
Jump to: