HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
Making threads to link to banned members content grants an automatic ban
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 problems with shading changes

View previous topic View next topic Go down 
AuthorMessage
Hamilton

avatar

Game username : Hamilton
Server : Myatar Legends // Dragon's Den
Female Posts : 379
Join date : 2011-10-20
Age : 31
Location : everywhere

PostSubject: problems with shading changes   Sat Nov 28, 2015 9:04 pm

So...I wanted to toy around with changing the way the shading is displayed on everything (for now, i'm just focusing on the player models) and after some hiccups...

well....it's better if i just show you what has happened so far.
(the material, program, and cg scripting were all obtained via the ogre wiki code snippets)

it's...clipping? wut?:
 
This was before i noticed i'd forgotten to move key image files to the right place, but is still an accurate representation of one form of my problem.
In this instance, I have added the celshading trigger only to the end pass for technique1 and technique2. This causes the shading to show up (yay) but also causes this odd sort of clipping. I'm not entirely sure WHAT it's doing but it almost seems like the model has two textures at the same depth...one with no shading, one with shading. Similar to if you placed a water-plane at exactly ground level on a flat terrain. So...not good...(note of importance: I have not made a full attempt at changing the lighting in technique2. this has since been attempted. there was no marked improvement)

omg no what even is that?:
 
This is with the celshading trigger applied to every pass in the material. The shading itself comes up very nicely. but as you can plainly see....the texture is so very very VERY wrong.
Adding extra passes causes the model to loose all texture (display white), so trying to apply it to each mask layer is a little moot.


I haven't even fully decided if I like the look or not. But having it actually working would help decide that matter so...

Anyone got some advice/assistance/experience in this matter? x.x
Back to top Go down
ObeyTheFist

™
avatar

Game username : ObeyTheFist
Server : Dragon's Den
Female Posts : 514
Join date : 2012-09-07
Location : Australia

PostSubject: Re: problems with shading changes   Sun Nov 29, 2015 1:20 am

I know strange clipping can occur across multiple layers due to cull_hardware none being in the material file. That's about all I can help you with. ^^;
Back to top Go down
http://dragonsden.freeforums.net
Hamilton

avatar

Game username : Hamilton
Server : Myatar Legends // Dragon's Den
Female Posts : 379
Join date : 2011-10-20
Age : 31
Location : everywhere

PostSubject: Re: problems with shading changes   Sun Nov 29, 2015 4:33 pm

I'm not sure if I can call this fixed or not. The original issue is still present...but it can be circumvented by changing the motherloving rendering to opengl. (I stopped using it back in v2 or 3 of IT because my old computer wouldn't render foliage or presets properly with it...)

*sobbing* i don't know what to do anymore. this is ridiculous. on one hand its fixed, on the other...what about users who play using direct?


at least....at least it looks pretty....
Back to top Go down
 
problems with shading changes
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support-
Jump to: