HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
Making threads to link to banned members content grants an automatic ban
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 Slow loading with obfuscated encryption

View previous topic View next topic Go down 
Go to page : Previous  1, 2
AuthorMessage
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Slow loading with obfuscated encryption   Sun Nov 22, 2015 4:47 pm

First topic message reminder :

Whenever I log in to test something, character loading stays stuck unless I click and the game, up in the corner, says 'not responding' and then it works. If I log off using the Quit button, it says game.exe has stopped working before it quits. I have obfuscated encryption installed (thanks to those who helped)

Is there any way to prevent it from doing this?
Back to top Go down

AuthorMessage
Cloud
Texture Artist
Texture Artist


Posts : 614
Join date : 2014-07-22

PostSubject: Re: Slow loading with obfuscated encryption   Mon Nov 23, 2015 7:38 pm

I'm using 5.5. The only thing in the changelog that seems like it would be useful to me is that I see 'fix to encryption.cfg' Do I need something like that?

Other than that it just shows the adding of encryption. Under 5.5 it says the Raknet upgrade.
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2575
Join date : 2011-07-24
Age : 30

PostSubject: Re: Slow loading with obfuscated encryption   Mon Nov 23, 2015 8:44 pm

Then there shouldn't be anything wrong with the load speed. Dragon's Den can attest to that

________________________________
Retired
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Mon Nov 23, 2015 8:52 pm

For obfuscated, it took forever to load the characters. It usually wouldn't load at all unless I clicked it and it said the program stopped responding, then it would work. I'm not sure what Dragon's Den uses, either obfuscated or zip automation.

I can't get to the setup screen at all. Whenever I click the game exe, it gives me this:

13:13:28: OGRE EXCEPTION(5:ItemIdentityException): Cannot find an archive factory to deal with archive of type KITOZIP in ArchiveManager::load at C:\kito\git\sources\dependencies\ogre_src_v1-7-4\OgreMain\src\OgreArchiveManager.cpp (line 67)


I swear I followed the directions exactly for zip automation, I use 5.5, not sure what's wrong. xD
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2575
Join date : 2011-07-24
Age : 30

PostSubject: Re: Slow loading with obfuscated encryption   Mon Nov 23, 2015 9:02 pm

These three files must exist with the following code:
https://github.com/jespersh/KITO/blob/v5.5/src/client/include/MagixEncryption.h#L79
Code:
   Ogre::Archive *createInstance( const Ogre::String& name )
    {
        // Change "OBFUSZIP" to match the file extension of your choosing.
        return new MagixEncryptionZip(name, "KITOZIP");
    }

https://github.com/jespersh/KITO/blob/64f792ce578a12d7aa7bfee1a5b8a0068e787bf8/src/client/src/MagixEncryption.cpp#L401
Code:
const Ogre::String& MagixEncryptionZipFactory::getType(void) const
{
    static Ogre::String name = "KITOZIP";
    return name;
}

https://github.com/jespersh/KITO/blob/v5.5/src/client/include/MagixApplication.h#L223
Code:
   virtual void setupResources(void)
    {
 // Create the factory for handling encrypted zips
 mMagixEncryptionZipFactory = new MagixEncryptionZipFactory();
 Ogre::ArchiveManager::getSingleton().addArchiveFactory(mMagixEncryptionZipFactory);

________________________________
Retired
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Mon Nov 23, 2015 9:26 pm

Okay. How am I supposed to get those files? Because I know for positive I don't have them.

I do have MagixApplication though.
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2575
Join date : 2011-07-24
Age : 30

PostSubject: Re: Slow loading with obfuscated encryption   Tue Nov 24, 2015 6:56 am


________________________________
Retired
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Tue Nov 24, 2015 7:50 pm

Okay, I looked through my source and I saw them in there. But they're not part of the project itself, that's why I didn't think I had them. I'm assuming they need to be added in there?


EDIT: Okay, added the MagixEncryption.h and .cpp to the project, changed any "KITOZIP" to "skynazip" and added the changes to MagixApplication (as the other two already had those changes)

It recompiled fine but when I tried to play it still gave me the same error.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Thu Nov 26, 2015 12:47 pm

It's still giving me the can't find archive to support KITOZIP error, to clarify
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2575
Join date : 2011-07-24
Age : 30

PostSubject: Re: Slow loading with obfuscated encryption   Thu Nov 26, 2015 2:08 pm

Means that one of three diffs on http://www.kitopen.com/t3953p16-slow-loading-with-obfuscated-encryption#33370 are not there. Including the "KITOZIP"

________________________________
Retired
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Thu Nov 26, 2015 2:22 pm

So you're saying that somewhere it says the file extension is KITOZIP when it should be skynazip? I'm pretty sure I got them all but I can check again
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2575
Join date : 2011-07-24
Age : 30

PostSubject: Re: Slow loading with obfuscated encryption   Thu Nov 26, 2015 4:30 pm

No.
#define ENCRYPTION_EXTENSION ".kzip"
Means the file extension is .kzip

So the resources file must be like this:
KITOZIP=media/scripts/scripts.kzip

The KITOZIP is absolutely required unless you changed something in the three diffs I linked.
The .kzip is changable.

________________________________
Retired
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Slow loading with obfuscated encryption   Thu Nov 26, 2015 10:48 pm

Okay, I found my mistake, fixed it, and now I can get in game <3 thanks Redeye!
Back to top Go down
 
Slow loading with obfuscated encryption
View previous topic View next topic Back to top 
Page 2 of 2Go to page : Previous  1, 2

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support :: Solved Support Issues-
Jump to: