HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 -SOLVED- Cannot Locate Resource .Skeleton

View previous topic View next topic Go down 
AuthorMessage
ShadoWolfozo

avatar

Game username : ShadoWolfozo
Server : GROWL: Spirits
Male Posts : 875
Join date : 2012-01-22
Age : 22
Location : Australia

PostSubject: -SOLVED- Cannot Locate Resource .Skeleton   Mon Apr 27, 2015 8:12 am

I need to stop being impatient about getting things fixed because I've solved several of my past issues by myself sometime after posting for help.


I was missing the part where I had to Scale/Rotate to Obdata the ARMATURE as well as the mesh- working with items all the time you only have to scale/rotate the mesh, never the armature-or at least I haven't- so I didn't even think to do that. 

Welp, there's the solution if anyone else is dumb like me and has the problem Cool


I've been having issues exporting critters for a long time- they'll look 100% fine in blender, export seemingly fine and then turn into retarded monster shaped disasters when spawned in-game and I've only just noticed this in the OgreXMLConverter.log file;
Code:
16:02:07: Skeleton: Loading warthog.skeleton
16:02:07: OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource warthog.skeleton in resource group General or any other group. in ResourceGroupManager::openResource at ..\src\OgreResourceGroupManager.cpp (line 753)
16:02:07: Unable to load skeleton warthog.skeleton for Mesh conversion. This Mesh will not be animated. You can ignore this message if you are using an offline tool.




But I have no idea why it's having problems trying to find it? But not only that.. it DOES animate in-game with the animations I've made, just horribly deformed.







The mesh was imported as an .obj file and the armature I made and animated myself. Both are present in the .blend file, are weight-painted and animate fine IN BLENDER.




I have tried everything in currently existing support threads and nothing has fixed it.


I have:
-Scaled/Rotated to ObData
-Made Modifier Real
-Exported several times
-Snapped to grid
-Made sure both the origin on model and armature are at 0,0,0 even after snapped to grid
-Made sure model and armature are the same scale in blender
-Made sure animations all work in Blender




What am I missing????


Last edited by ShadoWolfozo on Mon Apr 27, 2015 10:19 am; edited 1 time in total
Back to top Go down
RedEye
Retired
avatar

Game username : -redeye-
Server : KITO
Male Posts : 2578
Join date : 2011-07-24
Age : 30

PostSubject: Re: -SOLVED- Cannot Locate Resource .Skeleton   Mon Apr 27, 2015 9:45 am

Sometimes writing stuff out makes it obvious to one self.
Keep it up

________________________________
Retired
Back to top Go down
ShadoWolfozo

avatar

Game username : ShadoWolfozo
Server : GROWL: Spirits
Male Posts : 875
Join date : 2012-01-22
Age : 22
Location : Australia

PostSubject: Re: -SOLVED- Cannot Locate Resource .Skeleton   Mon Apr 27, 2015 10:18 am

RedEye wrote:
Sometimes writing stuff out makes it obvious to one self.
Keep it up


Yes very true! I think this may have been why I have solved it myself, seeing everything that I have done right in front me and then going to try things I know I haven't done!

And at the very least, it means if I or someone else ever does it again then we know there's a simple fix for it Smile
Back to top Go down
Sponsored content




PostSubject: Re: -SOLVED- Cannot Locate Resource .Skeleton   

Back to top Go down
 
-SOLVED- Cannot Locate Resource .Skeleton
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support :: Solved Support Issues-
Jump to: