HomePortalFAQSearchMemberlistUsergroupsRegisterLog in
Meet the new KITO admins & hear their plans here.
You can use google search to find threads and posts here now. Example

Share | 
 

 Connection problem again (FIXED)

View previous topic View next topic Go down 
Go to page : Previous  1, 2, 3, 4  Next
AuthorMessage
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Connection problem again (FIXED)   Sat Nov 01, 2014 8:54 pm

First topic message reminder :

Connection problem again lmao.
So this time neither I and Cloud can connect. o.o
She put my IP adress in Gameconfig,something like that xD Sent me the files and I added that localip.txt but I still can't connect.
Yes,I portforwarded and turned off my firewall but it still doesn't let me connect.
(Yeah,I tuned on gameserver and loginserver)


Last edited by Alex912 on Thu Jan 15, 2015 3:42 pm; edited 1 time in total
Back to top Go down

AuthorMessage
Alex912



Posts : 87
Join date : 2014-10-15

PostSubject: Re: Connection problem again (FIXED)   Sun Nov 30, 2014 10:45 am

I port forwarded it but it still doesn't allow me to connect.
Spoiler:
 
I have no idea where did I fail
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Sun Nov 30, 2014 12:57 pm

You did have gameserver and loginserver open, right? And tried with and without the localip?
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Sun Nov 30, 2014 2:14 pm

Yes
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Tue Dec 02, 2014 12:06 am

Should I redownload the source code, compile with the IP, and give Alex that? The only way I can get in game is with campaigns and I really don't want to do that.
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 2:05 pm

I placed localip.txt in client folder,I put in that code 127.0.0.1,opened servers and run the game.
I could connect,but my friend Cloud couldn't,so I replaced the 127.0.0.1 code with my IP adress and none of us was able to connect. Then I put my hamachi IP,I could connect but my friend couldn't. Can someone help us this time???
Back to top Go down
KetsuNika

avatar

Game username : xKetsuNikax
Server : Forging Zero {Private Server} <Owner>
Female Posts : 172
Join date : 2014-03-14
Age : 18
Location : Portland, OR

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 8:09 pm

Alex912 wrote:
I placed localip.txt in client folder,I put in that code 127.0.0.1,opened servers and run the game.
I could connect,but my friend Cloud couldn't,so I replaced the 127.0.0.1 code with my IP adress and none of us was able to connect. Then I put my hamachi IP,I could connect but my friend couldn't. Can someone help us this time???

I'll try and help to the best of my knowledge.

1. Delete the localip.txt from the game root, it's only if you want to be the only one to connect, also your Hamachi IP isn't suppose to go in here, it goes in GameConfig of the code where it says;

Code:
#define MAIN_SERVER_IP "putyourHamachiIPhere" // enter your server address


and,

2. Are you sure that you're running loginserver.exe BEFORE gameserver.exe?

From the info you've currently given, that's all I can come up with at the moment. Try it and inform me if it does or does not work, if it doesn't work then i'll see what else I can do to help.
(Also, if anything, you can run a joinme and i'll see if I can find anything that could be causing problems that you've overlooked.)

ShadowBlade~
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 9:03 pm

Okay. I think we've already tried with the Hamach IP in the compile, and Alex couldn't connect. We have tried with and without the localip. We'll try again, I'll link Alex back to this post.
Back to top Go down
Revaen
Very Helpful
Very Helpful


Male Posts : 314
Join date : 2013-07-21
Age : 16

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 9:10 pm

Unless you guys don't show pictures and steps of how you guys did the things(Detailed) we shouldn't know at all what's going on.

There are lot of facts that may affect the connection and there's certain steps to make it work properly.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 9:25 pm

I'll see if I can get Alex to post screenshots of what she's done.
Back to top Go down
KetsuNika

avatar

Game username : xKetsuNikax
Server : Forging Zero {Private Server} <Owner>
Female Posts : 172
Join date : 2014-03-14
Age : 18
Location : Portland, OR

PostSubject: Re: Connection problem again (FIXED)   Sat Dec 06, 2014 9:28 pm

Yeah, I agree with what Zflylexka said, without images it's hard for the rest of us to figure out what's going on.
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 07, 2014 10:59 am


Does this show enough?
I'm not sure what do I need to show you. x3
Back to top Go down
Revaen
Very Helpful
Very Helpful


Male Posts : 314
Join date : 2013-07-21
Age : 16

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 07, 2014 4:09 pm

It's probably a source/compile or Hamachi bad working, even, the router of who host.

It would be helpful if @Cloud show a screenshot from how she wrote the IP of Hamachi in her compile and if @Alex912 tell us to confirm if her IP is static and show the same IP of her Hamachi server which is being used in the compile.

Out of that, I believe I won't know what else may affect the host, since, indeed, Hamachi is pretty accessible(in certain situations, you may need to modify your Hamachi settings for make it work properly!).
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 07, 2014 4:19 pm

Okay. I'll screenshot the compile and post it here asap.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Tue Dec 09, 2014 12:20 am

Sorry guys for the terribly late reply. >.<

The IP shown in the picture is the Hamachi IP. I also had just recompiled with the Hamachi IP again so show that it's compiled into the compile. I didn't change the server password as I am unsure of what to do with it.

Spoiler:
 
Back to top Go down
ShadoWolfozo

avatar

Game username : ShadoWolfozo
Server : GROWL: Spirits
Male Posts : 875
Join date : 2012-01-22
Age : 22
Location : Australia

PostSubject: Re: Connection problem again (FIXED)   Tue Dec 09, 2014 3:50 am

I have never used hamachi for hosting but is that the ip YOU got from hamachi to te ip your HOST got? It may be because hamachi is giving you a different ip to what your host is getting. Meaning you need to compile with the ip your HOST is getting Because he is the one hosting, nt you.

Spelling errors courtesy of my phone.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Tue Dec 09, 2014 11:23 am

Alex created the Hamachi network and I joined it. I compiled with the IP Hamachi gave us.
Back to top Go down
Revaen
Very Helpful
Very Helpful


Male Posts : 314
Join date : 2013-07-21
Age : 16

PostSubject: Re: Connection problem again (FIXED)   Tue Dec 09, 2014 11:40 pm

Well, everything seems normal...for what I saw.

The last thing I would say and need to repeat is that probably there's a relay tunnel in your Hamachi server in both of you people or hamachi is not working due certain reason.

I had say that you guys need to find external help at Hamachi's support forum or a help of someone who knows host with Hamachi(since is not that hard to make it work properly and only certain facts may affect this).

Good Luck.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Wed Dec 10, 2014 12:39 am

Okay. Is there anything else we can use besides Hamachi?
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 14, 2014 1:07 pm

Soo...Anything other than Hamachi?
Back to top Go down
KetsuNika

avatar

Game username : xKetsuNikax
Server : Forging Zero {Private Server} <Owner>
Female Posts : 172
Join date : 2014-03-14
Age : 18
Location : Portland, OR

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 14, 2014 7:57 pm

Alex912 wrote:
Soo...Anything other than Hamachi?

I used to use Tunngle before I switched to Hamachi... Maybe Tunngle will work for you?
Here's the link to Tunngle: click me!
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 14, 2014 8:20 pm

Thanks,we'll try that
Back to top Go down
KetsuNika

avatar

Game username : xKetsuNikax
Server : Forging Zero {Private Server} <Owner>
Female Posts : 172
Join date : 2014-03-14
Age : 18
Location : Portland, OR

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 14, 2014 8:30 pm

Alex912 wrote:
Thanks,we'll try that

No problem, notify me if it doesn't work and i'll try and help seems I used to use Tunngle alot I know how to solve most of the bugs/glitches you may encounter using it.
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Sun Dec 14, 2014 8:35 pm

Does Tunngle give you an IP?
Back to top Go down
Ngendi

avatar

Female Posts : 35
Join date : 2014-03-11
Age : 16

PostSubject: Re: Connection problem again (FIXED)   Mon Dec 15, 2014 5:58 am

Have you changed the Ports in the solution?
Spoiler:
 
Back to top Go down
Cloud
Texture Artist
Texture Artist
avatar

Game username : Cloud, Daydream
Server : None
Female Posts : 614
Join date : 2014-07-22
Location : Under your bed

PostSubject: Re: Connection problem again (FIXED)   Mon Dec 15, 2014 11:20 am

No, I left those. Alex portforwarded to those as well.
Back to top Go down
Alex912

avatar

Game username : Alex912
Female Posts : 87
Join date : 2014-10-15
Age : 20
Location : Croatia

PostSubject: Re: Connection problem again (FIXED)   Thu Dec 25, 2014 5:40 pm

Okay,Cloud connected to Tunngle.
What do we do now? I can't find the IP we need to use in compile.
Back to top Go down
Sponsored content




PostSubject: Re: Connection problem again (FIXED)   

Back to top Go down
 
Connection problem again (FIXED)
View previous topic View next topic Back to top 
Page 2 of 4Go to page : Previous  1, 2, 3, 4  Next

Permissions in this forum:You cannot reply to topics in this forum
Keeping I.T. Open :: SUPPORT :: Support :: Solved Support Issues-
Jump to: